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1 Introduction 

BlomURBEX is a collection of Web Services provided by Blom that allow to 

navigate through high-detailed maps with ortho and oblique imagery, and to fly 

through 3D immersive cities. In addition, the Web Services can be invoked to 

obtain measurement information about buildings and other map elements. 

Blom leverages in Europe and around the world the production of a huge image 

and 3D model database of more than 900 cities, and the database increases each 

month as new countries are included in it. BlomURBEX offers the most detailed 

and comprehensive imagery database and 3D models of urban places in the 

market. 

Based on the same interface, Blom is developing a full range of Plug-ins that 

integrates BlomURBEX services in common GIS and CAD applications. Blom 

development roadmap with BlomURBEX includes the following targets: 

 

 BlomURBEX Plug-in for ESRI ArcMap (ArcView, ArcEditor and ArcInfo) 

 BlomURBEX Plug-in for ESRI ArcIMS 

 BlomURBEX Plug-in for ESRI ArcGIS Server 

 BlomURBEX Plug-in for Intergraph Geomedia Professional 

 BlomURBEX Plug-in for Integraph Geomedia WebMap 

 BlomURBEX Plug-in for Autodesk Map and AutoCAD 

 BlomURBEX Plug-in for Autodesk MapGuide 

 BlomURBEX Plug-in for Bentley MicroStation 

 BlomURBEX Plug-in for MapInfo Professional 

 BlomURBEX Plug-in for MapInfo MapXtreme 

Contact Blom at http://www.blomasa.com/contact.html for new releases and 

updates. 

 

 

 

 

 

 

 

 

 

http://www.blomasa.com/contact.html


 

BlomURBEX™ Plug-in for MapInfo

 

 6 

 

2 Version changes 

 
Version 3.5.0 of BlomURBEX Plug-in for MapInfo includes these 

improvements: 

 

 Removed callback functionality causing Mapinfo crashes, and replacement 

with new buttons in BlomURBEX toolbar inside Mapinfo. 

 Better stability. 

 Fixed bug causing certain projections to not work. 

 The bugs fixed are these: 

 #190 - A problem showing cooordinates on top of the images and 

in the status bar. Also a new option has been added that allows to 

copy the coordinates of the status bar with a double click in it. 

 #903 - Images are not correctly seen in a finish library that was 

having problems. 

 #841 - Suomi translation not correct. 

 #852 - Last oblique is still visible when the datasource is unloaded. 

This is due to the cache design and works as expected. 

 #1031 - Oblique imagery is not seen correctly. 

 #853 – Mapinfo plugin has been resedigned to avoid crashes due to 

bad callback support in Mapinfo API. 

 
Version 3.0.0 of BlomURBEX Plug-in for MapInfo includes these 

improvements: 

 

 Added support for adding Blom Library as a data source. 

 “Display measurement tool results” option has been removed from 

“Printing” options in “Settings”. 

 Better navigational controls for map. 

 Proxy settings will now get detected automatically. 

Version 2.5.2 of BlomURBEX Plug-in for MapInfo includes these 

improvements: 

 

 Fixed an error that causes a crash when viewing obliques. 

 OSGB36 projection supported. 

 Fixed a problem for viewing overlays in one view of multi-view layouts. 

 Fixed a problem refreshing overlays in obliques. 

 NTLM and Kerberos proxy authentication support 

 

Version 2.5 of BlomURBEX Plug-in for MapInfo includes these 

improvements: 

 

 All the rendering is done asynchronously. 

 Height measurement now uses a BlomURBEX service to obtain the best 

angle in the oblique image to force the measurement in a vertical direction. 

 Better resize to avoid flickering. 

 Vector overlay on top of oblique imagery can be done through a bilinear 

interpolation, fastering the rendering. This is now the default option for 

overlapping vector data. The option can be changed or deactivated in options. 
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 A new option in settings can change the priority order for the basemap. 

Now it is possible to prioritize between the different ortho images (“pictometry”, 

“Countryortho” or “satellite”) present sometimes at the same zoom level in the 

server. 

 Other tile layers in BlomURBEX server can be overlapped selecting them in 

the options dialog. 

 This user manual has been expanded with information about how to add 

BlomURBEX services as WMS layers. 

 Product and version number appears in About dialog. 

 Print error that occurred after printing is fixed. 

 Tooltips close when the map looses focus. 

 Default zoom and orientation has been fixed. 

 Views are now correct when changing between different layouts. 

 This manual contains information about how to save BlomURBEX toolbar 

position. 

 Bug fixed with double sync between map and BlomURBEX viewer. 

 Bug fixed with Extract image tool. 

 Proj4 DLL is no more used, but DotSpatial is used instead. 

 Installer uses bootstrap to download from web required prerequisites. 

 More accurate measurements in distance and area. 

 

Version 2.0.3 of BlomURBEX Plug-in for MapInfo includes these 

improvements: 

 

 Use of DLL calls instead of DDE deprecated technology that makes more 

stable the Plug-in. 

Version 2.0 of BlomURBEX Plug-in for MapInfo includes these improvements: 

 Internet Explorer 7 not needed. New BlomURBEX viewer do not requires 

Internet Explorer 7 to be installed or any other web browser. The Plug-in manage 

requests on its own. 

 A new image cache owned by all the Plug-ins speeds bitmap recovery and 

makes it easy to manage the Plug-ins cache. No more the browser cache is used. 

 Easier installation. BlomURBEX viewer component is not a previous install 

requirement. Plug-in installer checks if viewer is installed, and if not, then installs 

it. The viewer is never uninstalled to avoid other Plug-ins to stop working. 

 Better performance. New BlomURBEX viewer is not JavaScript based but 

.NET based, and executes code faster. 

 New option to choose the date of the imagery, allowing to see history 

changes in images, and seeing different years in a side-by-side mode. 

 Year of the current visible image in a label at the bottom of each view. 

 Intelligent behaviour when zooming. If a better view mode or orientation 

exists for current zoom then it is loaded automatically. 

 Faster vector overlay on obliques. The new BlomURBEX viewer sends 

fewer requests to transform vector data between ortho and oblique, and draws 

vector data faster. 

 Better geometry support. Now holes in polygons are supported and also 

multi geometries. 

 More symbology supported. Vector overlay is rendered in BlomURBEX 

viewer maintaining more symbology settings from MapInfo. 

 A new button in toolbar to enable/disable vector overlay faster than 

changing settings. 

 Print improvement. Print and export now support vector overlay. 

 Log levels to better grained logging and a default folder for storing logs in 

just one file. 
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 A new tool for extracting images has been added. If image exported is 

ortho view, then the world file is saved for easy use in GIS packages. 

 Proxy settings support 

 Full support of Windows versions from XP to 7, including 32 and 64 bits 

versions. 

 

 

 

 

 

 

 

 

 

 

 

3 System requirements 
 

MapInfo Professional 

BlomURBEX Plug-in for MapInfo supports versions 11.5 and 11.0 of MapInfo 

Professional. It is required to have any of these versions installed in order to 

execute BlomURBEX Plug-in for MapInfo. 

Microsoft .NET Framework 2.0 and 3.5 (installed by setup if not present) 

BlomURBEX Plug-in for MapInfo is developed with Microsoft .NET Framework 2.0 

and 3.5. During installation, if these Frameworks are not present, they are 

downloaded and installed. 

User Token 

To access BlomURBEX Web Services a UserToken is needed. This UserToken is an 

encrypted string that authenticates each user request. To access BlomURBEX 

offline libraries a license file is needed. Contact with Blom Marketing Department 

to obtain the required UserToken or license file in: 

http://www.blomasa.com/contact.html 
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4 Installing BlomURBEX Plug-in for MapInfo 
 

Now the plug-in installation is very easy. The plug-in is a ZIP file. To install just 

unzip it to any preferred location. 

 

 

5 Starting with BlomURBEX Plug-in for MapInfo 
 

5.1 Setup the BlomURBEX Viewer Plug-in in MapInfo 
 

To execute the Plug-in, follow these steps: 

1. Start MapInfo Professional. 

2. Select the MapInfo menu Tools > Tool manager. 

3. Click in “Add tool...” button. The Add Tool dialog box opens. Type any 

name you want for BlomURBEX Plug-in in the Title textbox. Click in the “...” 

button to search for the BlomURBEX.MBX file you will have in the Plug-in 

installation folder. Type any description you want for BlomURBEX Plug-in. Then 

click OK to accept. 
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4. The BlomURBEX Plug-in will be added to the list of current Plug-ins for MapInfo. 

Select the new Plug-in in the list and check the Loaded checkbox to load the Plug-

in, and the “Autoload” checkbox if you want the Plug-in to get loaded whenever 

you open MapInfo. 

 
5. Click OK in the Tool manager. You will see now the Blom toolbar with several 

buttons.  This is a onetime setting. From now on the BlomURBEX plug-in will 

appear anytime inside Mapfinfo. 
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In MapInfo Professional last versions it is not possible to save the position of the 

toolbars and they will open each time in a default location. Relocate to the 

prefered position whenever needed. 

 

5.2 Adding Data Sources 
 

To start using the BlomURBEX plug-in first is needed to configure the plug-in. The 

first task is to set the location of the data to use. A Data Source is a repository of 

complex cartographic data. 

 

Current version of Plug-in supports two different Data Sources: 

 

1. BlomURBEXTM online services 

2. Blom Libraries offline 

It is possible to use only one of them at the same time. 

5.2.1 Adding BlomURBEXTM as a Data Source 

To add BlomURBEX online services as a datasource, follow this steps: 

1. Open the BlomURBEX Viewer with a click in the “Show BlomURBEX window” 

button in the BlomURBEX plug-in toolbar. 

 
2. After some seconds the BlomURBEX viewer opens. Initially it should show a black 

map with no data, some zoom controls in the map, and a toolbar. In the 

BlomURBEX Viewer toolbar, select the menu Settings > Open settings dialog, to 

open the Settings dialog. 

 
3. In the dialog select General tab. 
4. In the Data Source drop down select “BlomURBEX”. 
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5. In the “User token” textbox type the UserToken provided by Blom. This 

UserToken is an encrypted string that authenticates each user request. Contact 

with Blom Marketing Department to obtain the required UserToken. The 

UserToken is needed to connect to the BlomURBEX Web Services and allow the 

access to the imagery. 

 
6. Click OK button to finish configuration. 

5.2.2 Adding Blom Library as a Data Source 

1. Open the BlomURBEX Viewer as previously indicated. 
2. In the BlomURBEX Viewer toolbar, select the menu Settings > Open settings 

dialog, to open the Settings dialog. 
3. In the dialog select General tab. 
4. In the Data Source drop down select “Blom Library”. 
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5. Select the Blom Libraries: 

 Click in the button with the ellipsis. Browse for a Blom Library folder. 

Select the root folder of the library to add. 

 Click “add new” button in order to add multiple libraries. 

6. Select Library Licenses: 

 Click in the button with the ellipsis. Browse and select a valid License. 

 Click “Add New” button in order to add multiple licenses in case there 

are more than one library. 
7. In order to remove a Library or a License, click delete button next to it. 

 

 
8. Click OK button to finish configuration. 

 

 

BlomURBEX Viewer in MapInfo is an independent window not dockable. MapInfo 

does not support dockable windows. 

 

 

5.3 Setup the BlomURBEX Viewer basic options 

The next thing to do in an plug-in that uses BlomURBEX Viewer is to specify some 

other options in order that the viewer can correctly search for images. For this 

follow the next steps: 

1. Open BlomURBEX Viewer window as previously indicated.  

2. In the BlomURBEX Viewer toolbar select the menu Settings > Open 

settings dialog to open the Settings dialog. 
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3. Select the Linking tab. It is needed to indicate BlomURBEX Viewer which 

projection has the currently opened map in MapInfo. Follow next steps: 

 

 
 

4. Click in the Select button to open the “Select projection” dialog. In the 

dialog select in the available projection list the one that the basemap has. There 

are different options to select the desired projection: 

5. To select a projection from the full list of supported projections, choose 

“Show all projections” in the upper dropdown box. To select click in the list and 

then click in OK, or double click an item in the list. Any item chosen will be 

reminded later in a list with the most used projections, so it is not needed to find 

it again in the long list. Also, it is possible to add any item to this “most used” list 

without leaving the dialog clicking with right mouse button and selecting “Add to 

most used” from the context menu. 
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6. To select a projection from the reduced list of the most used projections, 

choose “Show most used projections” from the upper dropdown box. The list will 

show only those projections selected at least once or any other marked explicitly 

as “most used”. To select click in the list and then click in OK, or double click an 

item in the list. Alternatively, it is possible to remove items from this “most used” 

list clicking with the right mouse button and selecting “Remove from most used”. 

The current selected projection cannot be removed from this list. 

 

 
 



 

BlomURBEX™ Plug-in for MapInfo

 

 16 

 
 

 
 

7. To select a projection from a reduced list using a filter, choose “Use a 

filter” in the upper dropdown box. The filter textbox and Filter button will activate. 

Type a search word or words in the filter textbox and press Filter. Only the 

projections containing the full search text will be shown. The search is possible by 

EPSG code and also by the projection name, and is case insensitive. To select 

click in the list and then click in OK, or double click an item in the list. The 

selected projection will be recorded in the “most used” list as usual. 
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8. Save the settings clicking in OK. Settings are saved in registry for each 

user so it is not needed to set them again later as each user has their own 

settings. The latest settings are used by default. To configure different settings 

use the Save button to save a file with the settings that can be later opened with 

the Open button. 

9. This finish the configuration.  

10. Now it is possible to start using the BlomURBEX Viewer. Skip the rest of 

the settings if the are not needed for now and proceed to next step “Viewing 

Blom images”. 

 

 

Settings do not persist, if the Plug-in is reinstalled. We need to set the settings 

again in case of re-installation. 

 

 

5.4 Changing language interface 

Language interface can be changed through the direct menu: Settings > 

Language, or through the Settings dialog, by Settings > Open Settings dialog. 

The first is a more direct way to change the language, but the results are the 

same. 

To change the language through the direct menu: 

1. Click in menu Settings > Language > <The desired language>. The interface 

language of the application is changed at once. The selection is saved in the user 

registry so next time BlomURBEX Viewer is opened the preferred language will 

remain in the interface. 
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To change the language through the settings dialog: 

1. Click in menu Settings > Open settings dialog. 

2. Select the General tab. In the Language selector, choose the preferred 

one. The interface language of the application is changed at once. 

3. If needed, click Save to save the settings in a file for future use. 

4. Click OK to save the settings in user registry. Next time BlomURBEX 

Viewer is opened the preferred language will remain in the interface. 

 

Improving translations of the interface is very easy. Check the Appendixes. 
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5.5 Changing layout 

 

BlomURBEX Viewer can show one or several orientations at the time using 

different layouts. It is possible to change from one layout to other either from 

Settings > Layout direct menu, or using the Settings dialog by Settings > Open 

settings dialog menu. The first is a more direct way to change the layout, but the 

results are the same. 

 

To change the layout using a direct menu: 

1. Click in Settings > Layout > <the desired layout>. The choice is saved in 

the user registry so this layout will remain in future sessions until changed again. 

 

 
To change the layout using the settings dialog: 

1. Click in Settings > Open settings dialog menu, to open settings dialog. 

2. In the dialog select the Layout tab and select the preferred layout in the 

upper dropdown box. For each view in the layout, it is possible to select the 

preferred year of the BlomURBEX imagery to be shown as explained later. 
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3. If needed, click Save to save the settings to disk for future use. 

4. Click OK to save the settings in user registry. Next time BlomURBEX Viewer 

opens the preferred layout will remain in the interface. 
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6 Viewing Blom images 
 

The BlomURBEX Viewer is the window that shows BlomURBEX images. To open 

an image is needed to select a location, either clicking in the basemap in MapInfo 

or introducing a known coordinates. 

6.1 Selecting location in MapInfo 

 

1. Open MapInfo with a basemap. 

2. Open BlomURBEX Viewer if it is not, clicking in the button “Open BlomURBEX 

window”. 

 

 
3. Ensure that settings are correct, as previously indicated. 

4. Resize and move application windows so they can be seen comfortably. 

5. Open any map data in MapInfo. The data can use any projection if it is in the 

EPSG list in the BlomURBEX Viewer options. It is only needed to know the 

projection and to indicate this projection in the BlomURBEX Viewer settings 

dialog. 

 

 

Remember when changing the projection in MapInfo, to modify the options in 

BlomURBEX Viewer. 

 

 

6. Ensure that the button “Searches BlomURBEX images in a point” is selected . 

7. Click in any location in the map. 

8. After some seconds BlomURBEX Viewer will open the best BlomURBEX images for 

that location, in all the orientations selected in the BlomURBEX Viewer layout. The 

images are centered in the selected point and show a crosshair. If no image 

appears consider if your BlomURBEX user permissions do not allow seeing images 

for that location. 

6.2 Introducing known coordinates in BlomURBEX Viewer 

1. In BlomURBEX Viewer toolbar click in the tool “Go to coordinates…” . The “Go 

to coordinate” dialog is opened. 
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2. Introduce a correct longitude or X and latitude or Y coordinates. Indicate the 

projection for this coordinates clicking in Select. This opens the same Select 

projection dialog that we see when selecting the basic options. By default, the 

last projection selected in the Settings dialog is offered here, but it can be 

changed, so we can ask for coordinates in any of the supported projections. 

3. Click OK. 

4. After some seconds BlomURBEX Viewer will open the best Blom images for that 

location, in all the orientations selected in the BlomURBEX Viewer layout. The 

images are centered in the selected point and show a crosshair. If no image 

appears consider if your user permissions do not allow seeing images for that 

location. 

6.3 Panning images 

“Panning” is the default behaviour of the display when no tool is selected. 

1. In BlomURBEX Viewer unselect any tool in the toolbar.  

2. Click and hold the left mouse button in the view to pan. 

3. Drag the image up, down, left, or right within the view, and finally release 

mouse. 

6.4 Magnifying images 

It is possible to zoom in for more detail or zoom out for more context information. 

Simply change the image’s magnification by using the zoom buttons on the 

toolbar. 

 

Zooming in all views 

 

Use the “Zoom In” button to increase the magnification of an image. 

To zoom in: 

1. Click the “Zoom In” button on the toolbar . 

2. The magnification percentage is doubled. (The part of the image that was 

centered in the display remains in the center). The “Zoom In” button affects all 

the images opened in the layout. 

3. Continue clicking the button until reached the desired amount of magnification. 

 

Zooming out all views 

1. Click the “Zoom Out” button on the toolbar .  The “Zoom Out” button affects 

all the images. 

2. The magnification is reduced by half. 

3. Repeat Step 1 until zoomed out the desired amount.  
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Zooming in or out with the mouse wheel in one view 

 

1. Move the mouse wheel frontwards or backwards to zoom in or out in just one 

view. 

 

Zooming to a extent in one view 

 

1. Unselect any tool selected in the toolbar so the “Pan” default tool activates. 
2. Press SHIFT key in keyboard. 

3. Click with left mouse button in any view and hold pressed. Drag to draw a 

rectangle. A rectangle appears showing the extent selected. Release button at the 

ending corner. 

4. Map centers and zoom to the best level zoom that contains the selected extent.  

This action only affects the view used. 

 

Zooming with the zoom bar in one view 

 

1. Each view has a zoom bar with a “+” button on top and a “-” button on bottom. 

Click “+” button to increase the zoom level, or “-” to decrease the zoom level. 

There are 20 zoom levels available for the “continuous” or “Ortho” view mode 

(see below about view modes). There are 6 zoom levels available for the “photo 

by photo” or “Oblique” mode. The last two levels in “Oblique” mode are a 

resample of level 4. 

2. Alternatively drag the level indicator up or down to increase or decrease any 

number of zoom levels. Every view in the layout has its own level indicator, so 

changes in this only affect the view that contains that level indicator. 

 

 

6.5 Changing views 

Initially each view in the layout has set an orientation, but it is possible to modify 

this selecting orientations orientation selector. In fact, it is possible to have the 
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same image several times. For example, it is possible to use the dual view to 

have two times the same ortho image opened. It can be useful to have a master 

– detail view to study two distant buildings at the same time that are in the same 

photo. Each time an orientation is changed in a view this setting is saved in user 

registry so it will be used until changed again. 

There are two types of view modes: “Ortho”, that shows the images in a 

continuous mode, and “Oblique”, that shows images one by one. In both modes it 

is possible to do “Pan” in the map endlessly. In the Oblique mode a new image is 

loaded in a seamless way when “panning” reaches the border of the current 

loaded image.  

 

 

 

Oblique imagery shown in a “continuous” or “Ortho” mode may suffer some 

distortion due to the irregularities of the terrain model that affects the ortho-

rectification process. In flatter terrains the distortion is less. 

 

 

 

Tools are unselected when the view mode changes. Remember to select again the 

tool if using one when the mode is changed. 

 

 

There are five types of orientations: “Ortho” orientation, that shows the image as 

an ortho-photo; “North”, that shows the image looking from south to north; 

“South”, from north to south; “East”, from west to east; and “West”, from east to 

west. To change the orientation click in the “O”, “N”, “S”, “E” or “W” buttons in 

the upper left control to activate the “Ortho”, “North”, “South”, “East” and “West” 

orientations, respectively. 

 

 

The size of each view in the layout can be changed through the use of splitter 

bars between the views. Just move the mouse in the boundary of two views, and 

when the cursor changes, drag and drop the splitter to change the size of the 

views. Each time the size is changed this setting is saved in the user registry. 
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6.6 The intelligent behavior 

At closer zoom levels, oblique rectified images show big distortion on the 

buildings, while at furthest zoom levels they do not offer better information than 

the ortho images.  

Each view in the BlomURBEX Viewer is configured in an intelligent way so that 

any request that attempts to change the zoom level of the view will check if the 

view is displaying any orientation other than Ortho, and in this case decide what 

set of images should be displayed: ortho, oblique rectified or natural obliques. 

6.7 Changing basemap ortho image 

By default the ortho image shown as basemap is one from several images 

available in BlomURBEX server. These images are visible are certain resolutions: 

 Satellite images, with low resolution of the data. This source data is 

available in the furthest zoom levels (1 to 13), and contains Blue Marble and 

Landsat 7 imagery. 

 Countryortho is imagery covering a whole country (or a region). This 

source data is available in the medium zoom levels (13 to 19), and contains 

imagery from several providers and from Blom. 

 Blom imagery captured with Pictometry cameras, also called “pictometry” 

images in the BlomURBEX server. This source data is available in the zoom levels 

with the maximum resolution (14 to 20). 

As can be seen at certain zoom levels these three sources coexist. For that zoom 

levels with more than one image available, the BlomURBEX server prioritizes first 

the “pictometry” image, then the “Countryortho”, and finally, the “satellite”. It is 

possible to change this priority in the options. 

In the textbox “Baselayer priority” of the General tab of the Settings dialog, 

change the text to consider other priorities in the images for the basemap. For 

example, in the next screen capture, the left shows the default priority with the 

“pictometry” imagery by Blom in the zoom level 18, and the right shows a 

different priority that renders the “Countryortho” imagery, that is also available 

for that zoom level. 
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Be careful to type the correct names in the Baselayer priority textbox, or no 

image will be shown. Type the names separated by commas and without any 

blank spaces. 

 

 

6.8 Showing the visible and total extension in MapInfo 

It is possible to see the visible and total extent of the opened Blom images drawn 

in MapInfo. To do this, follow these steps: 

1. In BlomURBEX Viewer, select the menu Settings > Open Settings dialog.  

In the Settings dialog select the Linking tab. Ensure that checkbox “Display image 

visible extent on linked mapping application” is checked for viewing the visible 

extent, and that checkbox “Display image total extent on linked mapping 

application” is checked for viewing the total extent. Uncheck the checkboxes to 

not see the extents in MapInfo. The total extent only has sense when the view 

mode is “photo by photo” also called “Oblique” mode. 
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2. Modify the visible extent of BlomURBEX Viewer by panning or zooming in 

the current image, or requesting other image. 

3. Now go to Mapinfo and click in the “Refresh image extents and cursor” in 

the plug-in toolbar each time it is needed to refresh the extens. Boundaries are 

drawn using a graphics temporary layer in MapInfo. By default visible extents are 

drawn in red and total extents in blue. 

 

 

6.9 Synchronizing views 

It is possible to synchronize the Mapinfo map to show the same position that the 

main view in the BlomURBEX layout. To do this follow this steps: 

1. Open the Settings dialog and select the Linking tab. 

 
2. Check the “Center linked map at main view center”. The main view in 

BlomURBEX is one of the opened views. To know what is the current main view 

go to the Layout tab in the Settings dialog. 

3. Now go to Mapinfo and click in the “Sync with viewer” button in the plug-in 

toolbar each time the location of the BlomURBEX main view changes. The Mapinfo 

map will be refreshed to show that location. 

 

 
 

6.10 Seeing historical images from different years 

It is possible to show imagery for different years in each view, facilitating user to 

follow the changes occurred in a spot of the city. To do this, follow these steps: 

1. Open the Settings dialog and select the Layout tab. 

2. For the current layout, a set of textboxes for each view is shown in the dialog. 

Enter a year or a range of years, inside these textboxes to filter that view for 



 

BlomURBEX™ Plug-in for MapInfo

 

 29 

a particular point in time. The date filter should follow one of these structures: 

YYYY-YYYY and YYYY, where YYYY is the year number with four digits. 

3. For example: “2005-2008” will return the most updated image available inside 

the range of years, including both bounding years. In this example, if an 

image of 2007 is available and no image in 2008 is available, then the image 

of 2007 is returned. But if no image is available between 2005 and 2008, and 

only an image of 2009 is available, then no image will be returned. 

4. Another example: “2006” will return the most current images available, whose 

date is previous to the requested date. In this case if several images are 

available previous to the year 2006 or from that year, then the last one will be 

returned. 

5. If the default value is empty, then the most updated image will be requested. 

6. If a wrong value is sent, then no image will be returned. 

7. The settings will affect also the Extract image or Export image tools when 

applied to the views with a date filter. 
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Above both views of Eiffel tower from 2008 and 2009 

 

The option to change the date of the BlomURBEX images allows to see side by side 

the same part of a city in different years. Up to five different years could be shown 

at a time. Just select the same view mode and orientation, as explained below, for 

each view in a multi-view layout, but choose different years for each view. 
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7 Obtaining image information 
 

To obtain the information about the current opened image, click in the Image Properties 

button in any status bar of the views. A panel will open showing extent coordinates in 

WGS84 lon/lat for the full image (in obliques) and for the visible portion and other data if 

available. To hide the panel click again in the button. 

 
Info in ortho view 

 
Info in oblique view 

To copy the image data just select the text in the panel, click the right mouse button, 

select copy, and paste it anywhere. 
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8 Using the measurement tools 

BlomURBEX Viewer offers various tools for measuring features visible in images. 

For example, it is possible to measure the distance between two points, the 

elevation of the terrain, building heights, bearing, area, perimeter, and the 

coordinates of a point. 

Before using the measurement tools, be sure that the unit of measure is set as 

desired.  

8.1 Changing units of measure 

To change units of measure: 

1. In BlomURBEX Viewer click the menu Settings > Open Settings dialog. The 

Settings dialog box opens. 

2. In the General tab click the desired units: Meters or Feet. 

3. Click OK. 

The changes remain in effect until units are changed again. 

8.2 Viewing the coordinates of a location 

Use the Location Tool to determine the location (the coordinates) of an object in 

an image. 

To determine the location of an object: 

1. In BlomURBEX Viewer click the Location Tool . 

2. Click the desired location on the image. 

3. The point’s coordinates appear drawn in the view. If the projection 

selected in the Settings dialog is not Spherical Mercator, the same coordinates 

will be seen in both systems, Spherical Mercator and the selected one, in the 

desired units, meters or feet. 

 

For Oblique images, remember to click near the base of buildings for more 

accurate coordinates. 
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8.3 Measuring squared perimeter or distance 

Use the Distance Tool to measure perimeter—the distance around the outside 

edge of an object or distances. 

To measure perimeter by using a parallelogram or measure distances: 

1. Click the Distance Tool . 

2. Starting with one corner of the object, click with the left mouse button. 

3. Click again for each new vertex. The outline of a polyline appears as new 

vertexes are added. In oblique mode take in mind that a workaround to the 

server must be done in each vertex and the measure takes longer. 

4. When the polyline surrounds the shape being measured or distance being 

measured, double click with left mouse button. 

5. The partial measurements and total length appears drawn in the view. 

 

8.4 Measuring bearing 

Use the mouse to draw one line to measure bearing both in ortho or oblique 

views. Where start drawing the line is important, as shown in the following 

illustrations: 
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To measure bearing: 

1. Click the Bearing Tool . 

2. Click with the left mouse button on the starting point. 

3. Click with the left mouse button on the ending point in the direction you 

want to measure the bearing of. The measurement appears drawn in view. 

 

8.5 Measuring area 

The Area Tool lets to measure the area of any linear shape both in ortho or 

oblique views. After the perimeter of the area to be measured is outlined, the 

area measurement appears drawn in view. 

To measure the area of any straight-sided shape: 

1. Click the Area Tool . 
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2. Click in the display at the desired starting point. 

3. Click again for every new vertex of the area. A polygon that returns to 

initial point is drawn automatically. 

4. When outlined the entire perimeter, double click in the last vertex. 

 

8.6 Measuring height 

Use the Height Tool to measure the height of an object in an Oblique image. 

(Because Orthogonal images are captured straight down, the Height Tool doesn’t 

apply to the “continuous” or “Ortho” view mode.) 

To measure height: 

1. Click the Height Tool . 

2. Click with the left mouse button on a point at the base (where it meets the 

ground) of the object we want to measure the height of. 

 
 

Important: Be sure to measure height by starting at ground level and moving 

upwards. If the ground level starting point is not seen, then estimate its location. 

 

3. Move the mouse upwards and click a new vertex at the ending point. 
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4. The measurement appears drawn in view. 

8.7 Measuring elevation 

Use the Elevation Tool to measure the elevation (height above sea level) of a 

point in an image. 

To measure the elevation: 

1. Click the Elevation Tool . 

2. Click the point whose elevation to measure. 

3. The measurement appears drawn in view. 

 

8.8 Clearing measurements 

Use the Eraser Tool to clear measurements in the map display. 

 

To clear measurements: 

1. Click the Eraser Tool . 

2. The measurements are removed in all available views. 

 

 

 

Start measuring 

here. 

Finish measuring 

here. 
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9 Printing images 

BlomURBEX Viewer let print all the views opened to the selected printer, setup 

the page options and preview the printing, along with the image properties if they 

were activated in the settings dialog. Before printing, scroll or pan the image so 

that the portion we wish to print is visible in the display. Also resize the views 

with the splitters and the size of the BlomURBEX Viewer window. The visible 

portion of each image, and with the exact pixel size, will be send to printer. 

9.1 Printing images 

To send all the current views to the printer with the current settings: 

1. Click the File > Print menu. 

 
2. The views are printed. 

Each view in the layout is printed in different pages also with the image 

information activated in settings. If the image information is longer than the page 

space, it will be cropped. In this case, try reducing the size of the BlomURBEX 

Viewer views or window, or limit the amount of information to print in settings 

dialog, as explained below. 

9.2 Changing print settings 

To change the printing settings: 

1. Click the Settings > Open Settings dialog menu. 

2. The settings dialog opens. Select the Printing tab. 

3. Check or uncheck the options wanted. 

4. “Display image properties” adds the corner coordinates of the image to the 

output (if the image is a oblique one) and other properties. 

5. “Display the visible extension of the image” adds the corner coordinates of 

the visible portion of the image. 

6.  “Display shot date” add to the output the shot date of the image. 

7. Click OK in the Settings dialog to save changes.  

 

 



 

BlomURBEX™ Plug-in for MapInfo

 

 38 

 

9.3 Page setup 

To change page settings: 

1. Click the File > Page setup menu. 

 
2. The Page setup dialog opens. Modify the page margin, orientation, etc. as 

desired. Click OK to accept changes. 

9.4 Print preview 

To preview the print: 

1. Click the File >Print preview menu. 
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2. The Print preview dialog opens. Click in the options to see the print at 

different zooms o layouts. Also it is possible to print clicking in the Print button. 

The dialog can be resized to full screen. 

 

The image shows the preview of a tetra view layout. Each view and its properties 

are print in different pages. 
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10 Exporting images 
 

10.1 Exporting all visible views 
 

The BlomURBEX Viewer “Export image” menu lets exporting the visible extent of 

the active views to a set of JPG files. 

To export an image: 

1. Pan in the views to display the extent desired. 

2. Click the “File > Export image…” menu. 

3. In the Save as dialog that opens introduce the path and filename for the 

file. 

The extracted image or images are saved with the filename specified. If the 

BlomURBEX layout shows several views, then several files will be created and all 

the files will be suffixed with a view number and orientation. Also, if view is in 

ortho mode, a world file (JGW) is saved for easy integration of the image in other 

GIS packages. 

 

10.2 Projection of the extracted ortho images 

The projection of the extracted ortho images are “Spherical Mercator”, the 

projection labelled by EPSG as 'Popular Visualisation CRS / Mercator' in March 

2008 with code number 3785. 
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11 Saving measurements 

BlomURBEX Viewer is able to save measurements in order to store this measures 

into any opened table in MapInfo. 

11.1 Setting measurement savings 

To activate the measurement storage, it is needed to complete two one-time 

setup tasks. It is needed to specify some options about the place where store the 

measurements, and some options about the units and the projection to use (in 

the case the measurements are locations). 

To specify the options regarding the place to store measurements: 

1. It is needed to have any map opened in Mapinfo, with at least one layer in 

the map where to store the measurements. 

2. Click in the “Refresh saving options” button in the plug-in toolbar to ensure 

that the BlomURBEX viewer obtains the information about current layers (tables) 

opened. 

 

 
3. Now go to the BlomURBEX Viewer. Click in the Settings > Open Settings 

dialog menu. 

4. The Settings dialog opens. Select the Saving tab. 

5. Select a table for saving measurements from the Table dropdown list. Only 

the tables of the layers available in the active map in MapInfo and the stand-

alone tables opened in MapInfo are shown. If the list of tables shown do not 

match current list of available layers in the MapInfo map window, to sync both 

lists exit the settings dialog with Cancel, and use again the button “Refresh saing 

options” explained above. Any time this tool is used the list of tables is refreshed, 

so use it again on the map after made any change in the MapInfo interface (as 

changing the active map window, or modifying the layers) to refresh settings 

lists. 
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6. Select a field for each type of measurement to save from the dropdown 

lists. It is possible to store seven different type of measurement. The table 

summarizes the relation between the BlomURBEX Viewer tools and the fields used 

to make the savings. 

 

In BlomURBEX 

Viewer the tool 

used is ... 

In MapInfo measurements are saved in the field 

selected in dropdown... 

 Column for areas 

 Column for distances 

 Column for heights 

 Column for elevations 

 Column for X coords and Y coords 

 Column for bearings 

 

7. To store only some measurements, select <None> for those 

measurements in the dropdown lists. 

8. Click in OK to save settings. 

To specify the options regarding the units and the projection to use in locations: 

1. Click in the Settings > Open Settings dialog menu. 

2. The Settings dialog opens. Select the Saving tab. 
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3. Select the desired units, meters or feet. The values will be stored in the 

units selected. 

4. Select the Linking tab. 

5. In the “Save location measurements” groupbox, choose “in Spherical 

Mercator projection” for storing location data in Spherical Mercator meters in 

MapInfo, or choose “in selected map projection”, more usual, for storing location 

data in the projection of the current map in MapInfo. This setting only affects the 

Location tool. 

6. Click OK to save settings. 

 

 

11.2 Starting and stopping save sessions 

In BlomURBEX Viewer it is possible to start, pause and continue the savings 

through an option. 

To start a save session: 

1. Click in the “File > Start saving measurements” menu if it is unchecked. 

The menu will toggle to a checked state and measurements will be stored (if 

fields were correctly set). 

To pause a session: 

1. Click in the “File > Stop saving measurements” menu if it is checked. The 

menu will toggle to an unchecked state and measurements will be paused. 

 

11.3 Procedure for saving measurements 

The procedure for saving measurements is this: 

1. Ensure that the current active map in MapInfo has a layer that matches 

the table selected in the BlomURBEX Viewer saving settings, or that a stand-alone 

table is opened that matches the table selected in BlomURBEX settings. Ensure 

that the fields selected are in this layer or table. If the layer or table is not 

present no saving will occur. If a field is not present, this field will be ignored. 
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Update anytime the settings to match them with the active map in MapInfo or 

stand-alone tables opened in MapInfo. 

2. Ensure that the “Start saving measurements” menu is checked so the text 

in the menu is now “Stop saving measurements”. 

3. Using the selection tools of MapInfo, select one or several map features or 

table records in the layer or table to update. BlomURBEX Plug-in only stores 

measurements in existing feature or table records, so create new records or 

features at your convenience prior to store measurements, and then select them. 

4. Now in BlomURBEX Viewer do a measurement as described above in this 

manual.  The values are saved internally. 

5. Now in Mapinfo click in the “Save last measurement” in the plug-in toolbar. 

The last measurement made in BlomURBEX Viewer will be sotred in the selected 

features in the map (in the layer and field selected in settings). 

 

 
6. Continue this way with other features or records. 

 

MapInfo showing the table of a buildings layer. A building is selected and elevation is 

obtained from BlomURBEX web services through the BlomURBEX Plug-in for MapInfo. 
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12 Overlaying tile raster data 

BlomURBEX Viewer is able to overlay tile raster data from BlomURBEX server, 

both in “Ortho” and “Oblique” modes. In next chapter is explained how is possible 

to overlap also local vector data loaded in MapInfo. Both tile raster layers and 

local vector layers can be overlapped at the same time over the BlomURBEX 

Viewer. They all are treated as layers and drawn on top of the basemap imagery. 

12.1 Activating and deactivating raster overlays 

To activate or deactivate the raster overlays follow these steps: 

1. Click in the Settings > Open Settings dialog menu. 

2. Select the Overlays tab. 

3. Each time the settings dialog in opened, a query is done to the 

BlomURBEX server to return the available tile layers for the current user. 

Remember when changing the UserToken option to close the dialog clicking OK 

button and to open again the dialog, because each UserToken has permission for 

different tile layers depending on user restrictions. Indeed, it is possible for a 

customer to host his vector data at BlomURBEX through a rasterization process. 

 
4. Select one or several layers from the list “Tile layer to overlay from 

server”. Click once to select and once again to deselect. 

5. Click OK to save the setting and start overlaying or clean overlays. This 

setting is not saved in user registry for better performance initialization. 

BlomURBEX Viewer always starts with the setting unselected. It is needed to set 

it explicitly in each BlomURBEX Viewer session. 
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Tile raster overlay with TeleAtlas streetmap 
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13 Overlaying vector data 

BlomURBEX Viewer is able to overlay vector data on top of BlomURBEX imagery, 

both in “Ortho” and “Oblique” modes. 

13.1 Activating and deactivating vector overlays 

To activate or deactivate the vector overlays there are two options with the same 

result: 

1. Click in “Overlay vector layers over BlomURBEX imagery” button in the 

URBEX toolbar .  

OR 

2. Click in the Settings > Open Settings dialog menu. 

3. Select the Overlays tab. 

 
4. Check or uncheck the “Overlay vector layers over BlomURBEX imagery” 

checkbox to activate or deactivate overlays, respectively. 

5. Click OK to save the setting and start overlaying or clean overlays. This 

setting is not saved in user registry for better performance initialization. 

BlomURBEX Viewer always start with the setting uncheck. It is needed to set it 

explicitly in each BlomURBEX Viewer session. 

 

 

Overlying on top of oblique imagery may be a long time operation. Be patient 

when overlaying a big number of features over oblique images. Read below for 

tricks to improve performance. 
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13.2 Refreshing overlays 

When Overlay option is activated all the existing layers in the MapInfo active map 

window are not added to BlomURBEX views inmediately. This option only switches 

on or off the overlaying process. To reflect these changes is needed to click in the 

“Refresh overlays” button in the BlomURBEX toolbar inside Mapinfo.  

 

(Ignore the “Reload overlays” button inside the BlomURBEX viewer, , this 

button is used only in plug-ins for other GIS packages).  

 

 
Before refreshing Vector layer 
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After refreshing Vector layer 

The “Refresh overlays” function cleans all the previous overlays, adds again the 

layers to BlomURBEX viewer and redraw again the vector data. Each time a 

change is made to the Mapinfo map, as adding new layers or features, or 

modifying any feature in its geometry, these changes are not shown immediately. 

It is needed to re-click again the “Refresh overlays” button. 

 

When overlaying vector data in oblique imagery, remember that vertexes of the 

geometries should match with the imagery at the ground level, not at the roof 

level. That is the reason of the apparent offset seen when overlapping over 

oblique imagery. 

 

 

13.3 Overlay and performance considerations 

To overlap geometries faster, a combination of requests to BlomURBEX server 

and local interpolations is done. It is possible to adjust the precision of the 

interpolations. 

For that, follow these steps. 

1. Open Settings dialog. 

2. Select the Overlays tab. 

3. The amount of points used for the interpolation determines the accuracy. 

It is possible to use no less than four points and no more than 400 points. 

Change this clicking up or down the “Points of interpolation” textbox. More points 

interpolate more accurately but are slower. Default is 100. 
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When Overlay option is activated, only visible features inside the visible extent 

are sent from MapInfo to BlomURBEX Viewer and rendered on top of BlomURBEX 

imagery. Try to limit the amount of features to be sent or the BlomURBEX Viewer 

performance will decrease when overlapping imagery. To limit the number of 

features follow this advices: 

 

1. Hide in MapInfo those layers that are not relevant. 

2. Zoom in inside “Ortho” BlomURBEX views so the visible extent contains a 

small number of features. Only features that fall inside the visible extent are 

overlaid. The zoom level is not a consideration in “Oblique” mode. 

13.4 Symbology limitations 

When rendering overlays BlomURBEX Viewer supports both types of MapInfo 

styles: the internal styles defined for each feature or the override style for the 

layer. If a override style is selected for the layer, then that style is used. If not, 

then the internal style defined for each feature is used. If no style is defined for 

the feature the default style is used. 

The BlomURBEX Viewer has less style properties than MapInfo. These are the 

limitations of the current version: 

1. Points are shown always as circles, but the size and color are correctly 

chosen. Outline color is always black. 

 
2. Polylines are always shown as solid lines, but the width and color are 

correctly chosen. Width must be in pixels. 
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3. Polygons are always shown as solid filled polygons with some 

transparency, but fill color and outline color are correctly chosen. Fill color is the 

one selected in the Foreground dropdown box when Pattern is Solid, or the one 

selected in Background dropdown box when Pattern is other. 

 

14 Adding BlomURBEX to MapInfo as WMS layer 

BlomURBEX offers a WMS (Web Map Service) service to allow access to the ortho 

images and the ortho-rectified obliques (oblique imagery shown in an pseudo-

ortho mode, projected over the ground). This WMS follows the directives and 

OGC’s regulation. This protocol is a service of publication of the cartography 

across Internet. 

The service gets a request from a client specifying the extent and size of the 

required image and returns the requested raster image. This raster image can be 

ortho view or any of the rectified oblique views. 

The service requires an HTTP request with a few parameters, normalized by OGC, 

which define the request. These parameters are: the service, the version, the 

type of request, the system of spatial reference, the coordinates of the area that 

define the spatial area of the request, the size of the image of response, the 

format of image, the layers, the transparency, etc. 



 

BlomURBEX™ Plug-in for MapInfo

 

 52 

This manual explains how to access BlomURBEX WMS services for MapInfo 

Professional 10.0 and above. 

14.1 Setting up BlomURBEX WMS services in MapInfo 

 

1. Open MapInfo. 

2. By default a toolbar named “Web services” is opened. If not open it. 

3. Click the “Web Services Preferences”. 

 
4. The “Web Services Preferences” dialog opens. In the Proxy tab select the 

correct settings for your Internet connection. 

 
5. In the WMS tab leave the default timeout values and pixel limits. Click in 

the “Servers...” button. 
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6. The “WMS Servers List” dialog opens. Click the Add button. 

 
7. The “WMS Server Information” dialog opens. In the “Server URL” textbox 

type the following URL: 

http://www.blomURBEX.com/v02/GetMap?usertoken=<your user 

token>&VERSION=1.1.1 
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where <your user token> should be the string with the user token. 

For example, if the usertoken is FDLKKFJSLKFS, then the URL will be: 

http://www.blomURBEX.com/v02/GetMap?usertoken=FDLKKFJSLKFS&VERSION=

1.1.1 

Type in the Description textbox any description as “Blom URBEX Server”. 

Finally click OK. 

 
8. The new BlomURBEX server is added to the list of servers of the “WMS 

Servers List” dialog. Select it in the list and click “Set default” to make it the 

default server. Finally click OK to dismiss the dialog. 

 
9. Finally click OK in the “Web Services Preferences” dialog to accept 

changes. 
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14.2 Adding BlomURBEX imagery as WMS ortho layer in MapInfo 

Follow these steps: 

1. Start MapInfo Professional if it is not. 

2. Add some data tables to a new MapInfo map. Data can be in any vector 

format supported by MapInfo, and in any projection supported by MapInfo. 

MapInfo will use the projection of the first layer added as the map projection. 

3. In the “Web services” toolbar click in the “Open WMS Table button”. 

 
4. The “Open WMS Table” dialog opens. In the WMS Server dropdown box 

ensure “Blom URBEX Server” (or whatever name description we typed for the 

BlomURBEX server previously) is selected. Select the “Ortho Images WGS84” 

layer in the WMS Layers list below the “Maps > Maps WGS84” group layer. There 

are five layers available: Ortho Images WGS84, North Images WGS84, South 

Images WGS84, West Images WGS84, and East Images WGS84. 

 
 

It would be better to select any of the layers available under the “Maps > Maps 

Spherical Mercator” group layer, because these layers are returned faster from 

the server. But current release of MapInfo Pro does not support the Spherical 

Mercator projection defined as EPSG: 3785, so for now ignore that layers. 
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5. Once one of the WGS84 layers is selected click Add to add it to the right 

list of layers to request. Leave the Style dropdown box with the <Default> value. 

Leave the Image format dropdown box with the default “image/jpeg” value. In 

the Projection dropdown box select the EPSG: 4326 projection as shown in the 

figure. Type “URBEXOrtho.TAB” as file name in the Table filename textbox instead 

of the default Untitled.TAB. Leave the rest with default values and select “Current 

mapper” in the preferred view dropdown box. Finally click OK to create a TAB file 

in the selected location with a link to the server and add that TAB file as a layer 

to the current mapper. After some seconds the BlomURBEX ortho layer will be 

shown under the rest of the map layers. If a “ERROR Unauthorized” message 

appear you should consider if the extent requested is too big (read below) or if 

your usertoken do not authorize to see the current map coordinates. 

 
 

Once a TAB file is saved with the BlomURBEX layer config, to add the layer to 

other maps it is not necessary to use again the “Open WMS Table” button. 

Instead, open that TAB file as any other TABs. 
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14.3 Adding BlomURBEX imagery as WMS ortho-rectified oblique 
layer in MapInfo 

 

Follow these steps: 

1. To add the North, South, West and East ortho-rectified oblique layers from 

BlomURBEX, follow the steps 1 to 4 in the previous section. 

2. In the “Open WMS Table” dialog, select any previous layer added in the 

right list and click “Remove” to clear all the list. 

3. Select in the WMS layers list any of the North Images WGS84, South 

Images WGS84, West Images WGS84, or East Images WGS84 layers. Be careful 

to select only one layer at a time. Click Add to add the layer to the right list. 

Leave the Style dropdown box with the <Default> value. Leave the Image format 

dropdown box with the default “image/jpeg” value. In the Projection dropdown 

box select the EPSG: 4326 projection as shown in the figure. Type a name as 

filename in the Table filename textbox instead of the default Untitled.TAB. This 

way each BlomURBEX layer will be configured in different TAB files. Leave the 

rest with default values and select “Current mapper” in the preferred view 

dropdown box. Finally click OK to create a TAB file in the selected location with a 

link to the server and add that TAB file as a layer to the current mapper. After 

some seconds the BlomURBEX ortho layer will be shown under the rest of the 

map layers. If a “ERROR Unauthorized” message appear you should consider if 

the extent requested is too big (read below) or if your usertoken do not authorize 

to see the current map coordinates. 

 
This figure shows the North ortho-rectified image layer. 
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This figure shows the West ortho-rectified layer as is rendered by default. 

 

4. As you can see from previous snapshot, the West, East and South 

orientations show the imagery by default in a weird way. But this is correct. 

These orientations are shown this way when the map has the north upwards. To 

render the map in a kinder way the map should be rotated. Follow the next steps 

for these cases. 

5. To rotate the map a free MapInfo tool will be used. In MapInfo select the 

Tools > Tool Manager Menu. The “Tool Manager” dialog opens. Select from the 

list of tools the tool named “Rotate Map Window” and check the loaded checkbox. 

Click OK to accept changes. The tool is added as a new menu in the Tools 

MapInfo menu option. 
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6. Before using the rotate tool it is needed to set up some options for the 

current map to allow image re-sampling. With the map active select the MapInfo 

menu Map > Options. The “Map Options” dialog opens. Click in the “Image 

Processing” button. 

 
7. The “Image Processing” dialog opens. Select Always or Optimized option, 

and Cubic Convolution or Nearest Neighbour. These options ensure that images 

are re-sampled when a transformation is applied to the map, as when rotating or 

reprojecting. 
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8. Click OK in both “Image Processing” dialog and “Map Options” dialog to 

accept changes. 

9. Now open the rotation tool selecting the Tools > Rotate Map Window > 

Rotate Map Window menu. The “Rotate Map Window” dialog opens. Click in “Map 

Center” to select the current map window center as rotation center. To rotate the 

West image, click in 90º; to rotate the East image, click in 270º; to rotate the 

South image, click in 180º. Finally click in Rotate button. After some seconds, the 

map will show the image and the rest of the layers rotated in a clear mode. 

 
10. This is the final rendering of the West image. 
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14.4 Projection issues 

 

BlomURBEX WMS services are provided in two different projections: WGS84 

Lat/Lon (EPSG: 4326), and Spherical Mercator (EPSG: 3785). Internally, image 

data is stored in Spherical Mercator, so this is the fastest option. When the image 

is requested in WGS84 Lat/Lon, the BlomURBEX server re-projects the image 

data on-the-fly in a slower process. To speed this process, an approximate affine 

transformation is executed. For this reason, the WGS84 Lat/Lon projection only is 

available for the highest zoom levels, with resolutions up to 150 meters per pixel. 

With lower zoom levels (higher resolutions), the re-projection process is not 

enough accurate. 

MapInfo has options that controls if raster data present in the map should be re-

projected or not to avoid long-time redraws of the map. These options are located 

in the “Map options” dialog that opens the Map > Options menu, in the “Image 

Processing” button. This button opens a new “Image Processing” dialog. Ensure 

that the Reprojection option is Always or Optimized. With any of this options 

checked, MapInfo allows to change the projection of a map with raster layers. If 

not, a message warning appears blocking the projection change. 
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When a BlomURBEX WMS layer is added to a map, if “Image Processing” is set to 

Never MapInfo will change the map projection, matching it with the BlomURBEX 

WMS layer. The reason for this change in the map projection is the Map options 

previously explained. If the image processing option is set to never reproject, 

then the map projection must match the raster layer projection. If you detect that 

MapInfo has changed the map projection, check if the reason is this. You can 

change again the map projection following the steps explained next. 

14.5 Changing the map projection with MapInfo options 

Each map in MapInfo has defined a projection. To know the projection of a map, 

select the menu Map > Options. In the “Map Options” dialog, click in the 

Projection button to open the “Projection” dialog. The projection selected in this 

dialog is the current projection defined for the map. If the layers added to the 

map have their geographic data in the same projection, then they are leave as 

they are, but if the layers have a different projection, then MapInfo will re-project 

data on-the-fly, without changing original data sources. 

 

 

If a new map is created and a projection is not defined for it, then the map will 

have the projection of the first TAB added. 
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This on-the-fly projection may be a long-time consumption process for raster 

data. To avoid this re-reprojection, MapInfo offers a “Image processing” button in 

the “Map Options” dialog that allows activate or deactivate the on-the-fly re-

projection. Ensure that the “Image processing” option is set to Always or 

Optimized to allow MapInfo re-projection of raster data. 

 

If a BlomURBEX WMS layer or any other raster layer is added to a MapInfo map 

and the “Image processing” option is set to Never resample images, the map will 

change its projection to the projection of the new raster layer added. This way it 

will be not needed to re-project, that is not allowed in the map options. To return 

the map to the previous map projection if has changed, it will be needed to 

change the “Image processing” option to Always or Optimized, and change the 

projection to the previous as explained below. 

 

 

Although BlomURBEX WMS services only support two projections (WGS84 Lat/Lon 

and Spherical Mercator), and the useful for current release of MapInfo is only 

WGS84 Lat/Lon, it is possible to set up MapInfo in order to see the BlomURBEX 

WMS imagery in any other projection supported by MapInfo. 

Once a BlomURBEX layer (with the WGS84 Lat/Lon projection) is added to the 

map, it is possible to change the map projection. To do this, follow these steps: 

1. Ensure that the “Image processing” option is set to Always or Optimized to 

allow MapInfo re-projection of raster data. 

2. Open the “Map options” dialog and the “Projections” dialog clicking the 

“Projection” button. 

3. Select any supported projection from the lists of the Projections dialog. 

4. Click OK both in the Projections dialog and the “Map options” dialog to 

accept changes. 

5. MapInfo will re-project any data presented in the map, both vector and 

raster layers, including the BlomURBEX WMS layers, to the new projection. 
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15 Uninstalling BlomURBEX Plug-in for MapInfo 

Unsintal is not needed because Mapinfo plug-ins are loaded on demand. Just go 

to Mapinfo, select Tools > Tool Manager, and in the Tool Manager dialog select the 

BlomURBEX plug-in, and click in Remove Tool to unregister the plug-in. 

 

16 Troubleshooting 
 

16.1 Log files 

If the applications do not work as expected, the best way to know what is 

happening is to activate the logging utility. 

In BlomURBEX Viewer, to activate logs, open the Settings dialog, and in the 

General tab, select the desired level for logs. A log file or several, one per 

process, will be created in the [User Application Data] \ BlomURBEX2D folder 

(usually c:\ Documents and Settings \<username>\Application 

Data\BlomURBEX2D). To deactivate logs just select “None” as log level. To 

activate logs select Error, Warning, or Information level (in order from minimum 

to maximum verbose).  

 

16.2 Cache directory 

The BlomURBEX Viewer creates a cache folder for faster retrieve of tiles. 
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To avoid this folder to resize to a big amount of bytes, it is possible to delete its 

contents periodically. Deleting the cache folder also ensures that the last tiles are 

downloaded. 

To delete the cache click in the Delete cache button from the General tab of the 

Settings dialog. 
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17 Frequently Asked Questions 
 

1. Why I do not see the visible and total extent of images in MapInfo? 

Ensure checkboxes in “Linking” tab of BlomURBEX Viewer Settings dialog are 

checked. 

 

2. Why the point I select in MapInfo is not exactly the same in the image in 

BlomURBEX Viewer? 

The data opened in MapInfo can be in any coordinate system. When digitizing this 

data, a coordinate system was used, defined by some parameters that describe 

the Earth and how to convert between projections. BlomURBEX Viewer uses the 

PROJ4 library to perform transformations between any projection and Mercator 

Spheric (EPSG: 3785), the default projection that use BlomURBEX Web Services 

at the moment. If the parameters used by the operator that digitizes the data 

opened in MapInfo and the parameters used in PROJ4 are not the exactly the 

same, some shift can occur in the location. In order to minimize this shift, it is 

possible to modify the epsg file that comes in the BlomURBEX install dir. The 

parameters must comply with the rules that expect PROJ4. To know more about 

this, check the appendix below. 

 

3. Why WMS layers are not seen in MapInfo when added? 

Check that the layers set to visible are “WGS84 layers”, because “Mercator 

Spherical layers” are not supported by MapInfo 9.5 as are defined now in 

BlomURBEX server. Also, check that the UserToken is valid and has permission to 

see image in the zone of the MapInfo map. Finally, ensure that the zoom of the 

map is closed enough. At far zoom levels, the WMS is not visible. 
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18 Appendix A: how to add new projections 

The projection support relies on the PROJ4 public domain library. In the 

installation folder of BlomURBEX Viewer a file “epsg” is provided that contains 

EPSG codes, names and parameters for the EPSG coded projections. If you need 

to modify an existing projection, or to add support for new projections, modify 

this file with any text editor following the PROJ4 rules for parameters. See the 

http://proj.maptools.org/ webpage for more information. 

For example, if support for the Microsoft Live Maps projection is needed, add the 

next two lines to the file (the second line looks longer but is only one): 

# World Mercator 

<54004> +proj=merc +lat_ts=0 +lon_0=0 +k=1.000000 +x_0=0 +y_0=0 

+ellps=WGS84 +datum=WGS84 +units=m  no_defs <> 

Or support for Google Maps projection: 

#Google 

<900913> +proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 

+x_0=0.0 +y_0=0 +k=1.0 +units=m +nadgrids=@null +wktext  +no_defs <> 

For optimize the Select projection dialog, delete from the “epsg” file any 

projection not needed. Remember that each projection in the file uses two lines, 

so do not break the format of this file or BlomURBEX Viewer could not work 

correctly. 

Once the “epsg” file is modified, open again the Settings dialog in BlomURBEX 

Viewer and reselect again the projection to refresh internal BlomURBEX settings. 

 

 

 

 

 

 

 

 

http://proj.maptools.org/
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19 Appendix B: how to improve interface translation 

BlomURBEX Viewer interface supports twelve languages. The strings for each 

language are stored in the registry, in the path HKEY_CURRENT_USER / 

SOFTWARE / Blom / URBEX 2.0. Each language has a section: english (en), 

español (es), deutsch (de), français (fr), italiano (it), nederlands (nl), portugués 

(pt), dansk (da), norsk (no), svenska (sv), suomi (fi), româna (ro). 

Each string uses a pair name-value. The name is an easy-to-understand name. 

For example, “AboutBoxForm.Description” is the description for BlomURBEX 

Viewer that appears in the About dialog. Change these values at your 

convenience using the registry editor. Next time you open BlomURBEX Viewer will 

reflect your changes. If any value is missing, the default value used is the English 

string. 

To return to original translation values, just delete de registry folder (da, de, en, 

and so on) of the language entries you want to reset. Next time that language is 

selected inside the plugin, the original entries will be restored in registry for that 

language. 
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20 Appendix C: how to view 3D cities with BlomURBEX 
Plug-in 

MapInfo supports the render of 3D objects through the use of a new window 

called Prism Map. In this appendix we will show how use the measurement saving 

capability of BlomURBEX Plug-in to render 3D cities. 

To view 3D cities follow these steps: 

1. Open a map in MapInfo and load a table with polygons representing 

buildings. 

2. Create a float field where store heights in the buildings table. 

3. Using the BlomURBEX Plug-in, store heights selecting buildings and 

measuring heights in BlomURBEX Viewer. 

4. In MapInfo select menu Map > Create Prism Map. If a warning appears 

requesting a editable layer, activate the buildings layers as editable in the Layer 

Control. 

 
5. In the Create Prism Map, select an appropriate color for background and 

light, and click OK. 
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6. In order to see the Prism Map correctly, you will need to change the zoom 

and location, using the Zoom & Pan tools, or using the 3DWindow > Viewpoint 

Control menu. To scale correctly the buildings, use the 3DWindow > Properties 

menu. 

 


